Engagement Login & Loading Delays

Incident Report for Dental Intelligence

Postmortem

Over the past two days, we experienced two separate periods of significant slowness, including difficulty logging in, caused by a recent tuning change to our internal message-processing systems that had an unintended impact on overall system performance. We have adjusted the configuration, restored normal performance, and put additional monitoring in place to catch similar issues earlier going forward. Patient message delivery remained within our service-level commitments throughout. Thank you for your patience.

Posted Aug 04, 2026 - 14:38 MDT

Resolved

This incident has been resolved. Engagement login and loading times have returned to normal.
Thank you for your patience while we worked through this issue.
Posted Aug 04, 2026 - 10:18 MDT

Investigating

We are currently investigating reports of delays affecting login and loading times for Engagement. Our engineering team is actively working on identifying the root cause.

We will provide updates as more information becomes available.
Posted Aug 04, 2026 - 10:03 MDT
This incident affected: Engagement (Engagement).