Analytics Access Issue

Incident Report for Dental Intelligence

Resolved

The issue has been fully resolved. To ensure your applications populate correctly, please clear your browser cache and sign out and back in.

We appreciate your patience while this was being worked on.
Posted Aug 25, 2025 - 07:58 MDT

Identified

Our engineering team has identified the issue affecting Analytics availability. A fix has been verified for a portion of impacted practices, and work is in progress to fully restore access for all remaining practices.

We will continue providing updates until Analytics is fully available for every practice.

Thank you for your patience while we complete the recovery process.
Posted Aug 25, 2025 - 07:42 MDT

Update

Our engineering team is fully engaged and working to identify the root cause of the issue preventing Analytics from loading. Restoring access remains our highest priority, and we are pursuing all paths to resolution as quickly as possible.
Posted Aug 25, 2025 - 07:11 MDT

Update

We are continuing to investigate this issue.
Posted Aug 25, 2025 - 06:40 MDT

Investigating

We are currently investigating an issue impacting customers attempting to load our Analytics platform due to a global outage. We’ll continue to share updates as new information becomes available.
Posted Aug 25, 2025 - 06:37 MDT
This incident affected: Analytics (Analytics Portal).