This incident has been resolved. Engagement login and loading times have returned to normal. Thank you for your patience while we worked through this issue.
Posted Aug 03, 2026 - 10:14 MDT
Update
A fix has been implemented and we are seeing improvement in loading times for Engagement. We will continue to monitor the situation to ensure the issue is fully resolved.
We'll provide a final update once we've confirmed full resolution. Thank you for your patience.
Posted Aug 03, 2026 - 09:46 MDT
Investigating
We are currently investigating reports of delays affecting login and loading times for Engagement. Our engineering team is actively working on identifying the root cause.
Please note: our support platform (phone, chat, and email) is also currently experiencing an outage, so response times may be delayed. We appreciate your patience.
We will provide updates as more information becomes available.